Nederlands Minecraft Forum

Minecraft => Problemen => Opgelost => Topic gestart door: ProBuilder op 16 januari 2016, 01:02:20

Titel: Error van Orebfuscator3 [Console]
Bericht door: ProBuilder op 16 januari 2016, 01:02:20
Hallo,

Sinds een tijdje heb ik Orebfuscator3 in de server alleen al vanaf het begin krijg ik deze error:
Toon inhoud
[13:11:16 INFO]: [Orebfuscator3] Enabling Orebfuscator3 v3.0.5
[13:11:16 ERROR]: Error occurred while enabling Orebfuscator3 v3.0.5 (Is it up to date?)
java.lang.NoClassDefFoundError: net/minecraft/server/v1_8_R2/Block
        at com.lishid.orebfuscator.internal.MinecraftInternals.isBlockTransparent(MinecraftInternals.java:30) ~[?:?]
        at com.lishid.orebfuscator.OrebfuscatorConfig.generateTransparentBlocks(OrebfuscatorConfig.java:120) ~[?:?]
        at com.lishid.orebfuscator.OrebfuscatorConfig.isBlockTransparent(OrebfuscatorConfig.java:105) ~[?:?]
        at com.lishid.orebfuscator.OrebfuscatorConfig.setBlockValues(OrebfuscatorConfig.java:338) ~[?:?]
        at com.lishid.orebfuscator.OrebfuscatorConfig.load(OrebfuscatorConfig.java:411) ~[?:?]
        at com.lishid.orebfuscator.Orebfuscator.onEnable(Orebfuscator.java:57) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot.jar:git-Spigot-db6de12-07c3001]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot.jar:git-Spigot-db6de12-07c3001]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot.jar:git-Spigot-db6de12-07c3001]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot.jar:git-Spigot-db6de12-07c3001]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot.jar:git-Spigot-db6de12-07c3001]
        at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:199) [spigot.jar:git-Spigot-db6de12-07c3001]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot.jar:git-Spigot-db6de12-07c3001]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_66]
Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_8_R2.Block
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[spigot.jar:git-Spigot-db6de12-07c3001]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot.jar:git-Spigot-db6de12-07c3001]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_66]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_66]
        ... 14 more


Weet iemand hoe ik dit kan oplossen?

Bij voorbaat dank!
Titel: Re: Error van Orebfuscator3 [Console]
Bericht door: simgar98 op 16 januari 2016, 07:53:25
De versie van je server en van de plugin zijn niet compatible, kijk naar waar de nieuwste versie voor is bedoeld en neem dat ook als server versie
Titel: Re: Error van Orebfuscator3 [Console]
Bericht door: ProBuilder op 16 januari 2016, 12:37:34
De versie van je server en van de plugin zijn niet compatible, kijk naar waar de nieuwste versie voor is bedoeld en neem dat ook als server versie

Ik heb nog is zitten zoeker naar anti xray plugins en toen kwam ik tegen dat je de config van spigot moet aanpassen op engine mode 2 en nu werkt het hetzelfde als orebfuscator :D